An Electric Scooter Community on a Mission to Stamp out Transportation Mediocrity.

Discuss the Segway Ninebot ES and Ninebot Max Kick Scooter in this Forum. Topics include the Segway-Ninebot app, hardware, street riding, etc.
By nkrsystem
Posts
#20987
Hi.
Friends two weeks ago I used the g30 generator to make some firmwares for a friend, a few days later when I tried to modify my segway es3 firmware I added the g30 firmware to Es_downg by mistake and flashed, the process it went well until 100% but then the display was blinking and beeping the red key came on (I don't remember if indicated any error in the screen) and the display didn’t turn off even after pressing a few seconds the button, the idea after this problem was to revert the firmware after turning off the display and turning it back on, the problem is that the scooter turned off after 1 minute or so by itself.

And after that the scooter never turned on again, today a friend flashed me the controller with the jtag and apparently it went well the controller have the correct voltage but does not have the 3.3 volts for the display anyone have any idea why the g30 firmware kill this controller/display or how to solve this problem.

The display that made the firmware update is working fine it was tested in another segway es4 so I think the problem is from the controller I searched the forum but I didn't found any post about this specific problem.

Thanks in advance.

Update:

Today I checked the smd resistor and it’s good so is not need to make a bridge between the smd, but I don’t have current in the display phase wires, tried to add a Step-Down Converter / Regulator Module 40v to 3.3v but when I connected the wires the regulator completely burst in seconds using the 40v on the board itself,after that I used an external battery connected to the display wires the green smd led light on and the red one too and so it worked and turn on the display this time already indicates error (18 board or engine failure), I can not understand is how only a firmware from segway max can burn the controller that was practically working well before the update.

To view images REGISTER or LOGIN for full access.

Yea, you have to drill that blind rivet, it's made[…]

NineBot Max - Attempt

I've read about that you had to use Ninebot ES4 da[…]

Thank you for the tutorial! finally! 99.9% complet[…]

Wheels 2.0 Rumors

Big news. I think I may have found a leak. It ha[…]