An Electric Scooter Community on a Mission to Stamp out Transportation Mediocrity.

Covers electric scooter models whether shared or for consumers.

radonek wrote:
Fri May 08, 2020 8:41 am
Mick Ray wrote:
Thu May 07, 2020 12:17 pm
radonek wrote:
Thu May 07, 2020 7:04 am
Yes, it works. With bluetooth hc 05 works perfect. I recommend Bluetooth commander for android, you can set periodically sending of code, it's fine when you get error 06e after some time.
I agree. But... Error 06E is annoying, because it's showing after 10 minutes of inactivity. Yes, you can send signal periodicaly but when you lost connection, you are frozen.
06E disappear also when you send any working command to controller. But it's not solving problem.
Really? Because when I send periodically code for turn on, I never get error 06e. Or when I let it turned on without sending any code and I get error 06e and then I send code for turn on, error disappears and display shows km/h. And I have mobile phone with myself everytime, so it's no problem run application for periodically sending turn on code. As I said Bluetooth Commander for Android is best for it. Another solution is Arduino, which can send it periodically too.
Yes, I agree with you. When it gets 06E, I can send any working command (even light on) and it dissapear. Also, sending command periodically solves problem. But as I said. Sometimes I have situation, that I can't send command, or phone dead, or other reason, and then I'm frozen with standard scooter.
radonek wrote:
Thu May 07, 2020 7:04 am
What is bad for me is minimal speed for start of motor (6 km/h), is any solution for starting motor from 0 km/h or lower speed than 6?
Other option is chinese controller. They starts from 0kmh. But for me good is that you have to get any speed to run - for safety reason. E.g. when you are at lights, is red, you waiting, and accidentially press throttle. It could be dangerous.

But... If you solve that throtle starts at 0kmh on original controller, you will also solve my 2 problems To view images REGISTER or LOGIN for full access.

1. To 06E dissappear,
2. To start original controller as enabled (default is disabled - when you cut battery from contoller, and connect again, it starts as disabled)

Silence... To view images REGISTER or LOGIN for full access.

So I have simple question:
How can I intercept that command? I have build "device" that connect green box and controller, but there are 2 RX and TX (I think it is not so important) that can read signal. When green box restarts, it sends some commands (viewed in Hex). If there is a command that unlocks controller how can I find it? Of course, intercepted when Green box is sending unlock command (like rent a scooter).
Standard command was but I don't know if it's still the same. Where, in that data I should look for?

Well, if you send the command to unlock the controller,
464316610001f1 {crc} mine throws back
46 43 16 11 00 03 f0 00 07 {crc}

So on the newest firmware, {mine is Santr. Fw. V 201119} there is now 3 bytes for the unlock code. It's telling me,
The motor...
Is locked...
And 3 byte is correct syntax, followed by crc is correct nomenclature.

Can anyone help now? I can screen shot if NEC.

Hello everyone, I'm in the same situation, pathed controller and no way to control the scooter other then flash the light and lock the wheel, no way to turn it on. Now, time ago i managed to create a serial sniffer, is very simple, even if it eas intended to be used on rs232 it should works well even on uart. Hope this helps!
To view images REGISTER or LOGIN for full access.

Today I tried to intercept data. I don't know if I done it right or wrong. I've created something like extension cable, with RX and TX cables to read data (one wire should be enough but I have both of them). Connected there by HC-05 and waiting for data. I monitored, that green box is sending sometimes something. When I restarted green box (strong magnet) I register some data.
It's not as on TheJoker187 plan above. Maybe I done it wrong way, but I tried.
So thinking that all is OK, I unlocked Lime scooter (renting it), then green box sent some data. I registered that there are lot of data like: check id, serial, make something like reboot, and command looking like enable scooter from earlier firmware. But sending it again to other patched controller doesn't work. Its like:

46 4316 61 00 03 F1 00 00 F8 AC

But... 4316 are "connected", I don't know if it should be like that. In my app hex fields sticked together means that is like new line. Maybe it should be like that:

46 43 16 61 00 03 F1 00 00 F8 AC

Anyway, that command don't work for me. Maybe I done something wrong, or whatever. I attach a log file from "unlocking" moment. There are mine commands, lines preceded with time (like: 13:02:43.779). So that's not green box but mine, to separate some data and find easier that moment.

Maybe someone can help?
(606 Bytes) Downloaded 24 times

  • 1
  • 12
  • 13
  • 14
  • 15
  • 16

Torrent: De Piraten Van Hiernaast Bande-annonce ([…]

Torrent: Animation Watch Movie Stream Desca[…]

Taking Screen Caps Off Blu Ray

Torrent: WATCH NOW! Solyom es galamb - 1. evad […]

i used this one and it worked https://pt.aliexpres[…]