An Electric Scooter Community on a Mission to Stamp out Transportation Mediocrity.

Covers electric scooter models whether shared or for consumers.
User avatar
By alecxs
#58368
PDruppo wrote:
Sat Apr 06, 2024 2:41 pm
For the battery indicator, it worked before. The only thing I can think of is that I flashed the same , original software from Emile that I flashed almost a year ago. Where there any changes to it?
Yes there were changes. I had similar issue with battery, try this fix (included in branch themed)
https://github.com/A-Emile/Lime_Gen3_Io ... nt/pull/14
PDruppo wrote:
Sat Apr 06, 2024 2:41 pm
Yeah, all lights are on, even when I kill power through the new main switch. But it was the same before. I just hoped it’s going to be fixed with the new hardware. I think I followed your instructions to the letter.
btw I am using Lime Gen3 25kmh locked.hex so the scooter is locked by default and can only unlocked with the app.
By PDruppo
#58389
I've used the unlocked 25km/h. The branch that you linked says it's for 20km/h.. also is this the ESP32 code or the controller one? I have no way of flashing the controller again (poured silicone into it).
I would like really badly to fix the battery error, but it could only involve flashing ESP32 again. Is this feasible?

If not, I have a 55V battery indicator (a simple one with 3 bars), if I connect it in parallel to the switch I added, should it then be showing me approximate voltage and thus battery status? Unless it should be connected in some other way? Any ideas how?
User avatar
By alecxs
#58390
PDruppo wrote:
Thu Apr 25, 2024 2:49 pm
The branch that you linked says it's for 20km/h.. also is this the ESP32 code or the controller one?
It's for the ESP32. It is a fix for a bug that I discovered while testing with the 20 km/h firmware. In the old version just 42 bytes are counted stupid. Once there is a byte offset, it will no longer receive correct messages. in the fix the function is listening for start sequence of 42 byte message. this ensures that every message is received correctly. any other noise is ignored.

this fix only concerns controller.ino
https://github.com/A-Emile/Lime_Gen3_Io ... roller.ino
  • 1
  • 19
  • 20
  • 21
  • 22
  • 23
New Lime Gen4 (V2) - Okai ES400A

Having an old EB100B OKAI Bicycle that has th[…]

SNSC 2.4

I have an older design 2.3 controller but with an […]