Electric Scooter Forum for Scooter Enthusiasts, Scooter Chargers, and Scooter Mechanics.

Discuss the Xiaomi mijia mi M365 original and pro versions in this forum. Topics include hardware, software, hacking, riding, and everything in between.
By michi_gecko
Posts
#11839
Hello,

For two weeks I have the M365 PRO Scooter, which is really nice.
But I experience two Problems or strange behaviour.

1. Error 40:
Seems to be quite rare, because there is not much to find over Google.
After going uphill in "S" Mode (sometimes also "D") this error jumps in very soon.
The Display shows the "40" in red, and the scooter stops. If turned off and on again, I can continue driving at once.
The App says Case Temperature above 90 Degrees Celcius which equals to 194 Degrees Farenheit.
BUT, it does not seem so hot really. It feels a little bit warmer than my hand.

2. Battery Status:
The Battery seems to regenerate. After driving 2 Miles I get a reading of e.g. 60 %.
But I can see the mAh count going up while standing. It even went up, when I had the Wheel spinning in the air.
After maybe 1-2 hours the reading says minimum 5 % more, than after I have stopped. Sometimes even 10-15 % more.

So my question: Is that normal? Doesnt seem so to me.
Should I send it back, or try to fix it by myself?

In general: How is the quality of new Xiaomi Scooters?

#12299
Hi am having a mi scooter pro, it's less than one month, am facing connection issues with my mi home app & dashboard is not showing Bluetooth option. Did you faced any such issues. I think for your issue try to adjust the app settings, use regeneration to the lowest in the app & try using only one mode, I only use sport mode. Then turn on cruise control it also helps reduce motor heating by keeping a steady speed.

#12338
Hi,

Regarding 1:
No, it is not normal at all. When you say that it does not feel hot on touch, do you mean the motor ? Because the error refers to the controller, which is located inside the scooter body, next to the battery. Such a high temperature after such a short ride is very alarming and can lead to fire inside the battery compartment. Therefore I would suggest to take it to electrician and avoid using it meanwhile. The cause of this might be something very trivial and easy to fix. If I had to guess I would say that most probably it is caused by a loose electrical connection.

Regarding 2:
I'm not sure, seems alright to me. If you are worried about the battery, you can install M365 Tools on your phone and check the battery voltages. You need to watch for a pack that has very different voltage than all others, if you don't have such then it is all fine. Differences less than 0.01v are completely fine

#12345
Thanks for the information.
So if it is the controller I should find the Problem quite fast.
I only read that the Pro Model has a too low motor constant in S mode.

Is there anything that can be optimized on the board, like better cooling connection or re-soldering some contacts?

By michi_gecko
Posts
#12915
Finally I found the source of the problem & also the solution.

After removing the controller case I could already see the problem.
To view images REGISTER or LOGIN for full access.


The NTC/PTC (not sure what they use) was between the Transistor and the case. You could see from outside, that the transistor was not touching the case properly. Therefore the transistor had no proper cooling, and the sensor got high temperature.

After removing the plastic cover everything fell apart.
Then I applied some heat conductiv paste on the transistor heatspreaders.
Everything was then put to place. Also I added some foam tape, so that there is more pressure on top of the transistors. I hope the thermal transfer is better with this.
To view images REGISTER or LOGIN for full access.


During re-assembling the controller case I found out, that the place for the brake wire is not optimal. It gets pressed down by the controller case. Resulting in a not so good contact of the case to the scooter itself. Also another part for bad thermal transfer. Also I did not like it, that the cable was pressed down over the quite sharp hole.
So I moved the cable up. It now runs between the outside wall right under the charging port.
To view images REGISTER or LOGIN for full access.


Finally I removed the original heat conductive paste and replaced it with better one. Just enough so that there is contact everywhere.

As last step I gently squeezed the cable connectors, so that they sit firmly on the pins.
That seems to be a common problem with this type of connectors. They might get loose by vibration.
To view images REGISTER or LOGIN for full access.


The battery pack is quite improved to the standard M365. I was curious how it would look inside. But it seems that the casing is sealed, so I did not open it.
To view images REGISTER or LOGIN for full access.


Temperature is now much lower, and it seems to work much better now.
Still I believe that the controller reduces the power as soon as the temperature goes up. As a guess after reaching 40 Degrees Celcius.
But it could also be the effect of the lower voltage. In my short test run uphill I went 10% down to almost 40% charge.
LAskooter213 liked this

#13074
I have just had this EXACT same problem on my PRO this afternoon! Thanks for the detailed explanation, I did notice burn marks on the blue wire as well. Have bent the resistors down a bit to make better contact with the aluminium case, but don't have any paste to ensure further heat spread. Like you, was surprised to see the tiniest smear of paste between controller box and base!

I was also going uphill... error 40, turned off, a restart would get it going again though.
michi_gecko liked this

#13096
Andrew Harding wrote:
Mon Jul 22, 2019 12:36 am
..., I did notice burn marks on the blue wire as well.

I was also going uphill... error 40, turned off, a restart would get it going again though.
That is curious, I also had burn marks on the blue wire. But I have no clue why.
To me it looked like the cable and the cable shoe is ok. No sign of burn mark on this components.

How steep/fast do you go uphill? Do you have a custom ROM installed?
I am trying to figure out the best balance between good speed and reduced power. It seems that the ROM goes 2-3 Ampere higher in usage, than set in the ROM.

#13108
Bizzare alright. I am running stock firmware 1.6.1 (latest) and hill is around 10 degrees for 10 minutes with my 95kg weight with the throttle all the way down in S mode.

Has yours overheated since you did this modification??

My mosfets were touching the case ok, but bent them slightly anyway to contact more. I also poured solder into the crimp of the blue connector to make sure it's not just a bad crimp as the burn marks point to that being the issue. I can't see any burn marks on the board either, all looks ok?

To view images REGISTER or LOGIN for full access.

#13109
No, I have not had any problem since.
Case temperature reaches 50 ° Celcius now.

I am more concerned about killing the motor. I managed to pump 1.000W into it. Seems too much for my feeling. But I was going 20kmh uphill, with about 7 Percent incline at maximum and 5 Percent average.

On the blue wire I had the burn mark on a different area. It is at the complete end of the wire. What I could see on your pictures you had it on the side, where the cable enters the cable shoe.

#13110
Good to hear, I'm quietly confident that it is the loose spade terminal that caused a resistence and hence the overheating, will know later today when i tackle the hill again after doing it last night, have ordered some thermal paste to try on the mosfets as well like you did. 50 degrees seems fine to me. I'm sure with a bit more work, paste and cooling mats, you could get this temp down even further.

The motors are quite durable from what I have read, it's the control boards and the flimsy wiring and connectors that cause this issue.... I hope anyway!

New Skip 3

You got any links to announcements or are you sayi[…]

@calorchard thanks for sharing your story. It he[…]

350w for WHEELS

I need help wiring the WHEELS e bike because i con[…]

Shared Scooters for Sale on OfferUp

Have no fear, I'm still here! :lol: I started a[…]