An Electric Scooter Community on a Mission to Stamp out Transportation Mediocrity.

Discuss the Xiaomi mijia mi M365 original and pro versions in this forum. Topics include hardware, software, hacking, riding, and everything in between.
By jdk
Posts
#15713
My m365 software is 1.4.2 and I flashed the firmware with these settings:
Maximum speed: 35km/h
Motor start speed: 2km/h
Motor power constant: 46000 (default is 51575 Lower = More power)

Yesterday I found that front motor brake doesn't work when the scooter is ON. I tried to flash back the default settings but no luck. Any ideas? To view images REGISTER or LOGIN for full access.
To view images REGISTER or LOGIN for full access.

By Robert Brown
Posts
#15746
jdk wrote:
Thu Sep 19, 2019 4:31 am
My m365 software is 1.4.2 and I flashed the firmware with these settings:
Maximum speed: 35km/h
Motor start speed: 2km/h
Motor power constant: 46000 (default is 51575 Lower = More power)

Yesterday I found that front motor brake doesn't work when the scooter is ON. I tried to flash back the default settings but no luck. Any ideas? To view images REGISTER or LOGIN for full access.
To view images REGISTER or LOGIN for full access.
The way I see it you either blew up your BMS, controller or dashboard (it sounds like you probably blew a fuse on one of the boards) Or it’s a firmware issue. If it’s a firmware issue you could buy a ST -link and try that but honestly if you flashed everything back to stock and it’s not working it’s almost certainly one of the boards.

Stm32 (ESC) and stm8 (display) And there is nrf (b[…]

I have controller and dashboard from Ninebot 4 and[…]

Battery charging cables

I think, it is communication line between BMS (bat[…]

Bird ES1 IoT hardware adapter

Hi. I have some. Would you buy them from me if I l[…]