An Electric Scooter Community on a Mission to Stamp out Transportation Mediocrity.

Discuss the Segway Ninebot ES and Ninebot Max Kick Scooter in this Forum. Topics include the Segway-Ninebot app, hardware, street riding, etc.



#7856
Edward wrote:
Wed Apr 17, 2019 4:50 pm
Need a little help! I have a bird Segway ES1 (I believe) that turns on for a second when you power on ,but then the dashboard goes blank. I am still able to ride it ,but there is no display. I checked my connections to the display and they are all good. Lights for front and brake are all functional just no display.. Someone please help. Thanks in advance.
I’m having the same issue, on an ES4. I’ve heard this is because it’s a set of Jump handlebars on a Bird body, but I’m not sure. Any thoughts? What should be replaced to get the display and Bluetooth to work?

#7902
Geoff160 wrote:
Sun May 05, 2019 10:45 pm
Edward wrote:
Wed Apr 17, 2019 4:50 pm
Need a little help! I have a bird Segway ES1 (I believe) that turns on for a second when you power on ,but then the dashboard goes blank. I am still able to ride it ,but there is no display. I checked my connections to the display and they are all good. Lights for front and brake are all functional just no display.. Someone please help. Thanks in advance.
I’m having the same issue, on an ES4. I’ve heard this is because it’s a set of Jump handlebars on a Bird body, but I’m not sure. Any thoughts? What should be replaced to get the display and Bluetooth to work?
The Jump dashboard has bluetooth turned off plus jump firmware. Follow the tutorials and flash it. Then the dash will not turn off. While your at it you can try to flash the firmware and get rid of the bird controller firmware.
Edward liked this


#8041
James007 wrote:
Tue May 07, 2019 3:03 pm
Geoff160 wrote:
Sun May 05, 2019 10:45 pm
Edward wrote:
Wed Apr 17, 2019 4:50 pm
Need a little help! I have a bird Segway ES1 (I believe) that turns on for a second when you power on ,but then the dashboard goes blank. I am still able to ride it ,but there is no display. I checked my connections to the display and they are all good. Lights for front and brake are all functional just no display.. Someone please help. Thanks in advance.
I’m having the same issue, on an ES4. I’ve heard this is because it’s a set of Jump handlebars on a Bird body, but I’m not sure. Any thoughts? What should be replaced to get the display and Bluetooth to work?
The Jump dashboard has bluetooth turned off plus jump firmware. Follow the tutorials and flash it. Then the dash will not turn off. While your at it you can try to flash the firmware and get rid of the bird controller firmware.
How exactly do I flash firmware? I bought a new display from eBay and everything worked great for about a minute. I was able to connect Segway app. Then as soon as I get on it to move everything goes blank and nothing works. Tried putting original dash back in and nothing. I think my main control board is fryed... I have no voltage going to dash now. I do have 37v on one of the wires. Everything else is Dead. Any help would be greatly appreciated.

#8061
Edward wrote:
Sat May 11, 2019 11:11 pm
James007 wrote:
Tue May 07, 2019 3:03 pm
Geoff160 wrote:
Sun May 05, 2019 10:45 pm

I’m having the same issue, on an ES4. I’ve heard this is because it’s a set of Jump handlebars on a Bird body, but I’m not sure. Any thoughts? What should be replaced to get the display and Bluetooth to work?
The Jump dashboard has bluetooth turned off plus jump firmware. Follow the tutorials and flash it. Then the dash will not turn off. While your at it you can try to flash the firmware and get rid of the bird controller firmware.
https://hackmd.io/s/Bki2fcWwE

How exactly do I flash firmware? I bought a new display from eBay and everything worked great for about a minute. I was able to connect Segway app. Then as soon as I get on it to move everything goes blank and nothing works. Tried putting original dash back in and nothing. I think my main control board is fryed... I have no voltage going to dash now. I do have 37v on one of the wires. Everything else is Dead. Any help would be greatly appreciated.
https://hackmd.io/s/Bki2fcWwE


#9961
I have 4 scooters, two of them work fine and the other two the battery level indicator doesn’t show, the Bluetooth won’t connect the ninebot app, it finds the scooter fine but won’t actually connect and the scooter doesn’t work, it won’t move. I’ve tried searching everywhere but I can’t find anyone who has had this issues and posted about it

  • 1
  • 28
  • 29
  • 30
  • 31
  • 32
  • 38

Hey, im searching a Scooter that could bei shipped[…]

@m365b Thank you for the valuable input, it is a[…]

Hi folks, i just finished the upgrade of an exter[…]

Just purchased BIRD ES1-300

Scooter is brand new I work for dish network and w[…]